ACME DNS-Challenge Hetzner über Proxmox

Hallo zusammen,

leider habe ich das Problem, dass mein Proxmox kein Zertifikat über die DNS-Challenge bekomme. Anbei die Config mit Fehlermeldung.

Könnte mir da bitte jemand behilflich sein?

Gruß Wombat

Screenshot 2023-10-13 212042

API-Key steht nartürlich drin habe ihn nur aus Sicherheitsgründen auf dem Screenshot entfernt

Es scheint mir trotzdem das Problem mit dem Key zu bestehen.

Versuch mal Ohne Anführungszeichen. Kontrolliere Leerzeichen beim API Key.
Die Fehlermeldung ist recht eindeutig, Fehler mit der API.

Probier mal HETZNER_Token="deinAPIkey", das hatte jedenfalls bei mir mal funktioniert.

2 Likes

@Axelander Vielen dank das ist die lösung

hi ich habe das gleiche Problem aber mit Ipv64.net .

Da heißt der Eintrag

IPv64_Token=
1 Like

Loading ACME account details
Placing ACME order
Order URL: https://acme-v02.api.letsencrypt.org/acme/order/1508813286/235649047336

Getting authorization details from ‚https://acme-v02.api.letsencrypt.org/acme/authz-v3/302729147446
The validation for xxx.xxx-network.de is pending!
[Wed Jan 10 16:34:47 CET 2024] invalid domain=‚_acme-challenge.xxx.xxx-network.de‘
[Wed Jan 10 16:34:47 CET 2024] Error add txt for domain:_acme-challenge.xxx.xxx-network.de
TASK ERROR: command ‚setpriv --reuid nobody --regid nogroup --clear-groups --reset-env – /bin/bash /usr/share/proxmox-acme/proxmox-acme setup ipv64 xxx.xxx-network.de‘ failed: exit code 1

bekomme immer noch die selbe meldung.

Okay lösung ist dann IPv64_Token=API ohne „“