Bei bestehender VPN-Verbindung leitet die pfSense auf die eigene Weboberfläche

Wenn ich z.B. mit meinen mobilen Geräten per WireGuard (bereitgestellt durch die pfSense bei Hetzner) mit meinem Cloud- und Heimnetzwerk verbunden bin (aus Gründen läuft dann sämtlicher Verkehr über die VPN-Verbindung), lande ich beim Aufrufen von im Heimnetz gehosteten Diensten nicht dort, sondern auf der Weboberfläche meiner pfSense.

Klar, die Anfrage kommt über das WG-Interface bei der pfSense an. Ich hätte jetzt erwartet, dass sie dann genauso weiter gereicht wird und dann über das WAN-Interface reinkommt, damit der dahinterliegende NGINX Proxy Manager gem. der Subdomain das ganze weiterreichen kann an den entsprechenden Server. Das klappt aber nur, wenn ich direkt (ohne VPN-Verbindung) auf der WAN-Schnittstelle lande.

Welche Einstellung in der pfSense habe ich vergessen bzw. so liegt mein Denkfehler?

Grüße
Boris

hast du iner System->Advanced den NAT Reflection mode for port forwards von disabled auf z.B. NAT+Proxy geändert?

1 Like

Ah, das war es. Herzlichen Dank!
Genau das habe ich gesucht, aber keine Einstellungen gefunden. Aus der Beschreibung heraus hatte ich das nicht an dieser Stelle vermtut. Aber es zeigt die gewünschte Wirkung :slight_smile:

gerne, ich hatte selber mal den fall