Micro Firewall Appliance 12th Gen N100

Hallo liebe Gemeinde,

ich habe mir nach Dennis seinen Video diesen Barebone Mini PC geholt, und mich an Proxmox gewagt.
Nun habe ich mir eine VM mit Opensense erstellt, nach einen YouTube Video, dort sollte man nach dem erstellen der VM erst die Netzwerk über Hardware & PCI hinzufügen.

Ich bekomme immer das die IOMMU nicht detected sind.
Dieses auch schon eingeben gehabt (intel_iommu=on) bekomme es aber nicht hin.
Im Bios habe ich auch nichts genaues gefunden. Kann mir jemand helfen dazu helfen ?


wo hast du den was genau eingetragen?

hast du auch folgendes dort eingetragen?

/etc/modules
image

und intel_iommu=on eingetragen

/etc/default/grub
image

update-grub und oder proxmox-boot-tool refresh nicht vergessen auszuführen vor dem reboot

wen es nicht automatisch gesetzt wird muss in dieser Datei auch noch angepasst werden

/boot/grub/grub.cfg

danke dir, habe die Eintragungen gemacht gehabt und jetzt noch nochmal kontrolliert und neu gebootet.
Leider geht es immer noch nicht.
hier das Bild der Netzwerke unter meinen PVE knoten.
muss ich dort evtl. was einstellen?
Ich möchte gerne enp3s0 als WAN port und enp4s0 als LAN Port zur UDM pro einstellen.

  GNU nano 7.2                                      /etc/modules                                               
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

vfio
vfio_iommu_type1
vfio_pci
vfio_virpfd

 GNU nano 7.2                                   /etc/default/grub                                             
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"
GRUB_CMDLINE_LINUX=""

update-grub und proxmox-boot-tool refresh hast du gemacht ?

hast du geprüft ob es in der Datei auch automatisch angepasst wurde?

/boot/grub/grub.cfg

z.b.

ich bin mir nicht ganz sicher von wo er sich das zieht, ich glaube aber das es von

/etc/default/grub

in die andere datei geschrieben wird beim update-grub

vielleicht ist ja auch das Board inkompatible oder es ist im BIOS deaktiviert ohne das du die Möglichkeit hast es zu aktivieren, oft sind gewisse feature aktiviert/deaktiviert im BIOS aber man hat keine Möglichkeit den zustand zu ändern weil die Option dafür nicht angezeigt wird, in der Proxmox GUI kannst du diesbezüglich nichts einschalten, das muss schon vom BIOS aktiv sein und im Kernel vom OS aktiviert werden

so sieht es erstmal alles ok, ich werde morgen versuchen nochmal in bios zu schauen, muss erst wieder einen Monitor dafür anschliessen :neutral_face:

Guten Morgen, leider finde ich Bios nichts dazu. Mein Bios ist ein AMI Aptio Vers. 2.22.1287.
Hat irgendjemand noch einen tip ? oder sollte ich versuchen Proxmox neu aufzusetzen ?
Eigentlich sind ja unter dem Netzwerken die 4 ethernet Schnittstellen zu sehen, bekomme die nur nicht der opnsense VM nicht zugeordnet. Oder habe ich was beim erstellen der VM falsch gemacht?

Mal so als Fragen zwischendurch… Wieso genau willst du die Hardware sao durchreichen ? Kannst ja auch bridges nehmen…

1 Like

Die Frage mit der Bridge ist gut, hatte es nach einen YouTube Video versucht, aber wie erstelle ich die Bridge um sie der VM zu geben.
Bin leider noch recht neu bei den Themen :slightly_smiling_face:

im Netzwerk Reiter unter „erstellen“ (genauer steht es in den Docs)

Danke euch für den Tips, habe nun jeden Anschluss als Bridge hinzugefügt und konnte ihn dann der VM als Netzwerk hinzufügen.
Muss jetzt nur noch den WAN Port zum laufen bringen.:grinning: