Nur IPv4 bei Abfrage erzwingen

Zum Telekom Speedport Smart 4 funktionieren (Stand März 2024) leider nur WireGuard-Verbindungen an seiner IPv4-Adresse.

Nun hat der spezifische Speedport Smart 4 Router an dem Internet-Anschluss eine IPv4- und eine IPv6-Adresse.
Der DynDNS Updater vom Speedport sendet beide IP-Adressen zusammen und kommasepariert, was bei nahezu allen DynDNS-Anbietern nicht funktioniert.
IPv64.net ist eine Ausnahme, es funktioniert fantastisch damit!

Die ipv4.-Subdomain zur Erzwingung eines nur-IPv4-Adressen-Updates verhindert nicht das Update/Einfügung des IPv6-Eintrags.
An sich ist auch nichts falsch daran, das Problem liegt an dem Router, da er ja, wie schon erwähnt, keine WireGuard-Verbindungen an seiner IPv6-Adresse unterstützt.

Gibt es einen Weg, die Antwort auf eine DNS-Abfrage einer IPv64-DynDNS-Domäne auf einen IPv4-Eintrag zu erzwingen? Z.B. als ipv4.-Subdomäne? Oder kann ein benutzerdefinierter Eintrag erstellt werden, welcher einen vorhandenen IPv64-IPv4-Eintrag (der dynamisch aktualisiert wird) als Wert verwenden?

Leider bietet IPv64 keine „DNS Resolver“ Funktion, sodass nur v4 Adressen gemeldet werden. Du kannst deine DynDNS-Update via IPv4 senden indem du ein „ipv4.ipv64.net“ nutzt, aber ein Resolving geht leider nicht.

1 Like

Danke für die Erklärung!

Das IPv6-Update ganz abgeschaltet, mit der Option
IPv4 / IPv6 am Updater ignorieren (/nic/update) ? [CG-NAT|DS-Lite]:
[Ignoriere IPv6 / AAAA Records].

Ein Feature, das DNS-Eintrags-Werte interpolieren kann (ähnlich wie ALIAS (der aber nur für den Apex verwendet werden kann) oder eine „magische“ IPv4-/IPv6-only Subdomain wäre aber eine nette Ergänzung!