Probleme Installation Grafana im Protainer

Hallo Gemeinde,

ich erbitte hiermit Eure Unterstützung bei der Einrichtung von Grafana in einem Portainer auf einem Raspi. Ich hatte bei der Installation für das Image eingegeben: grafana/grafana:latest, wie es im Video beschrieben wurde. Bei der Erstellung läuft das System auf den Fehler, dass es dieses Image nicht finden könne.

Auch bei allen weiteren Versuchen erhalte ich jetzt immer die Fehlermeldung: grafana/grafana:latest nicht vorhanden, auch wenn ich „:latest“ gar nicht mehr verwende. Es wird also immer wieder :latest angehangen. Wo kann ich dieses Problem im Portainer lösen bzw. Löschen, damit das System nur noch meine aktuellen verwendeten Daten bearbeitet?

Ich danke schon jetzt für Eure Hilfe.

Mit freundlichen Grüßen

Poseidon

schonmal versucht das image mit docker image pull grafana/grafana:latest vorab zu downloaden?

1 Like

hier auch mal mein docker compose, welchen ich als stack in portainer ausgerollt habe

version: '3.8'

services:
  grafana:
    container_name: grafana
    hostname: grafana
    image: grafana/grafana:latest    
    restart: unless-stopped
    security_opt:
      - no-new-privileges:true
    networks:
      - net
    ports:
      - "3000:3000"
    volumes:
      - data:/var/lib/grafana
    environment:
      TZ: Europe/Berlin

networks:
  net:
volumes:
  data:
1 Like

Hallo Pandora,

erst einmal vielen Dank für Deine Hilfe. Ich habe es heute noch einmal versucht, jedoch mit dem gleichen Ergebnis. Auch wenn ich „grafana/grafana“ alleine eingebe bekomme ich anschließend die Anwort das es das Image „grafana/grafana:latest“ nicht gibt und der Vorgang wird sofort abgebrochen. Ich bin da echt überfragt. Irgendwo muss das System „:latest“ gesichert haben, und hängt es automatisch an das von mir eingegebene Image an. Wir müssten die Datei, welche diese Erweiterung gespeichert hat, löschen bzw. editieren, damit dieses „:latest“ nicht mehr gefunden wird.

Danke im Voraus

Poseidon

Einfach mal etwas die docker doku lesen, es ist ganz normal das latest dran gehangen wird wen keine version angegeben wird, latest bedeutet nur das die aktuelle stable gezogen wird, versuch doch einfach mal mit pull das image zu ziehen

docker pull grafana/grafana

Was für hardware hast du? Grafana gibts nur für
linux/amd64

linux/arm/v7

linux/arm64

Hallo Andrew,

vielen Dank erstmal für Deine Hilfe. Diesmal hat es geklappt. Ich habe das Image mit pull erstellt und es steht nun als Container und Image in Docker. Was bei dieser Art der Installation jedoch fehlt sind die Pfade der Volumes. Trotz großen Suchens habe ich keine Möglichkeit gefunden die benötigten Pfade /var/lib/grafana und /opt/grafana dem Image hinzu zu fügen. Kannst Du mir da noch einmal auf die Sprünge helfen wo und wie man das Image nun mit den fehlenden Volumes komplettieren kann?
Vielen Dank schon mal im Voraus für Deine Unterstützung.

du kannst im Portainer volumes anlegen und dan den container mit Duplicate/Edit bearbeiten und bei „Advanced container settings“ die volumes hinzufügen