DynDNS an Speedport Pro Hybrid

Hallo,

auch ich habe Probleme mit dem Dienst am Speed Pro. Es gibt ja nun an dutzenden Stellen im Netz eine Anleitung und Tipps, leider an keiner Stelle mal Zusammengefasst was man nun an welcher Stelle (am Router und im ipv64 Account) wie Einstellen muss.

Ich habe nun alle Varianten probiert mit ipv4 und ipv6, immer kommt der Fehler im Router → Fehler bei der Anmeldung.

Dann habe ich es mal mit DuckDNS probiert, da funktioniert es auf Anhieb.

Hat das jemand hinbekommen mit einem Speedport Pro und kann mal einen Tipp geben was man wo einstellen muss.

mfg

Hast du dir mal diese Einsttelungen von ipv64 DynDNS Helper // Anleitungen auch probiert ?

Ja nach Anleitung bin ich gegangen.
Bei der Zeile Updateserver-Adresse habe dann Alle Varianten probiert die in den verschieden Foren kursieren. Die Anmeldung funktioniert einfach nicht.
Wenn ich die Aktualisierung manuell über die URL im Browser mache, erscheint der Record im Account.

Trage doch mal als Host einen HTTP-Request-Catcher ein (alles andere unverändert lassen),
z.B. https://requestcatcher.com/.
Dann kannst Du sehen, was genau der Speedport da eigentlich für eine Anfrage sendet,
u.a. HTTP Auth.

Da kommt zunächst nichts an. Wenn ich dann den Code im Terminal vom Server eingeben der auf der Seite steht, kommt dann das.

Ändere etwas an den DynDNS-Einstellungen und speichere die Einstellungen erneut, dass sollte den Speedport dazu veranlassen, das DynDNS-Update sofort durchzuführen.

Bei älteren Speedports kann/muss man in den Systemmeldungen nachsehen, ob warum ein DynDNS-Update nicht durchgeführt werden konnte:

  1. Einstellungen (oben)
  2. System-Informationen (Leiste links)
  3. System-Meldungen (Mitte, aufklappen)
    Dort nach einem Eintrag suchen, der von dem Zeitpunkt mit dem letzten Speichern der DynDNS-Einstellungen korreliert. Steht da eventuell eine Fehler-Meldung oder eine Notiz, dass ein DynDNS-Update versucht/durchgeführt wurde?

es kommt diese Meldung:
26.03.2024 23:32:38 D001 Aktualisierung für Dynamic DNS war nicht erfolgreich. Der Update Server konnte nicht erreicht werden.

oder diese Meldung mit den Angaben von ipv64:

25.03.2024 20:46:54 D002-1 Aktualisierung für Dynamic DNS war nicht erfolgreich. Der Dynamic DNS Anbieter meldet Fehler bei der Authentifizierung (badauth)

Habe den Router auch schon mehrfach neu gestartet, und die Einträge gelöscht und neu Eingetragen. Immer das selbe.

welchen key verwendest du denn?

  • subdomainkey (aus der url beim anker symbol)
  • domainkey
  • accountkey
  • api key

bitte einmal screenshots der oberflache vom speedport
am besten inkl. eingaben (anonymisiert, gerne auch per pm lesbar an mich)

1 Like

Das war wohl der HTTP-Request-Catcher, den der Speedport aus welchen Gründen auch immer, nicht erreichen kann (evtl. fehlende/veraltete TLS Root-Zertifikate?). Falls dieses Werkzeug noch benötigt werden sollte, einmal andere HTTP-Request-Catcher mit dem Speedport ausprobieren. Bei einem alten Speedport-Modell funktionierten bei mir auf jeden Fall einer von den bei Google als erstes angebotenen.

Der Speedport macht noch irgendetwas bei der HTTP Authentifizierung falsch, ansonsten aber doch schon ein gutes Zeichen.

Laut Anleitung für den Speedport von IPv64.net muss als Passwort der Update-Key verwendet werden, der Benutzername kann beliebig sein (nur nicht leer).

Ich hatte bei meinem Speedport zuerst den Fehler gemacht, den Account Update-Token/-Key anstatt des spezifischen Domain Update-Keys als Passwort anzugeben (wie @Pandora mit der Frage-Liste wahrscheinlich herausfinden möchte).

Den Update-Key habe ich in Erfahrung gebracht (geht das eigentlich auch eleganter/formeller?), indem ich die Seite der spezifischen DynDNS-Domain auf IPv64.net geöffnet und dann den Update-Key unter Domain Update URL als Wert des key-Parameters nachgesehen habe (mit dem Augen-Symbol die URL einblenden) (z.B. https://ipv64.net/update.php?key=<der Domain-Update-Key>).

Ergänzung zu alten Speedport-Modellen: Ich hatte bei einem älteren Speedport (welcher inzwischen aus anderen Gründen durch ein neues ausgetauscht wurde) festgestellt, dass manchmal nur ein kompletter Neustart des Speedports ein DynDNS-Update auslöste.

ich nutze den Account Update Token wie in der Anleitung beschrieben

Das Problem ist die Update Adresse glaube ich. Da muss eine bestimmte Kombination an Parametern rein, wenn man so die Lösungen bei der Telekom sieht. Aber welche?

Auch mit dem Domain Update Key geht es nicht.

Wie sieht denn der Konfigurationsbildschirm für DynDNS aus von Deinem spezifischen Speedport Modell? Existiert dort ein Feld Domänenname?

Auch sehr interessant (insbesondere der Bug in der Firmware):

Für nsupdate (ein ähnlicher DynDNS-Service) gibt es eine Lösung für die Speedport Hybrid Einstellungen:

Das Feld sieht Exemplarisch so aus.


Ich habe einen Speedport Pro Plus. Der wurde erst letzten Monat getauscht. Aktuelle Firmware ist drauf.
Die Anmeldung bei DuckDNS z.B. funktioniert ja ohne Probleme. Nur hier geht es nicht.

Wenn ich die Lösung auf GitHub richtig verstehe hat er bei Benutzername noch einmal das gleiche eingetragen wie bei Domainname?!

Folgende Einstellungen verwende ich (erfolgreich) auf meinem Speedport Smart 4 für IPv64:

Dynamisches DNS verwenden

Zugangsdaten
Anbieter: [Anderer Anbieter]
Hostname: <vollständige IPv64 DynDNS-Domain (z.B. meinesubdomain.ipv64.net)>
Username: <beliebig, darf nur nicht leer sein>
Passwort: <DynDNS-Domain-Update-Key der DynDNS-Domain>
Updateserver-Adresse: ipv64.net/nic/update (exakt so wie es links steht, ohne Protokoll-Prefix und keine Schema-relative URL (wie https://)!)
Protokoll: [HTTPS]
Port: 443 (der HTTPS default Port)

Nach dem Speichern wird bei IPv64 die DynDNS-Domäne sofort aktualisiert und auf der Speedport-Konfigurationsseite unter Aktueller Status Anderer Anbieter steht nach einigen Sekunden mit einem Grünen-Haken-Icon registriert.

Das funktioniert beim mir so nicht.
Das HTTPS stetzt der automatisch davon.

Was ich rausgelesen habe das es der Smart 3 anders macht als der der Smart 4, da haben die Leute schon Probleme gehabt. Der Pro macht es wieder anders, wie auch der alte Hybrid Router.

Was ich gelesen habe in der einer der Lösung, der Pro sendet stur das https://ipv64.net/nic/update und hängt dann den Suffix automatisch ran nach seiner Formatierung und das kann nicht jeder lesen scheinbar.

Hier noch mal als Test probiert mit DuckDNS.

Klappt sofort. Würde aber Trotzdem gerne ip64 nutzen.

Bei dem neueren Speedport Smart 4 werden beide IP-Adressen (IPv4 und IPv6) kommasepariert zusammen als Wert in der Anfrage verwendet. IPv64.net kommt damit aber klar (daher verwende ich es). Eventuell verwendet Dein spezifisches Speedport-Modell ein anderes, nicht unterstütztes Format.

Die Verwendung eines HTTP-Catchers (der mit diesem Speedport kompatibel ist) wäre sehr hilfreich:

bitte trage einmal diese url als update url ein

https://ipv4.ipv64.net/nic/update.php?output=min

alles andere wie gehabt

Nein Geht aucht nicht.