Nginx Proxy Manager LE Cert läst sich nicht erstellen Internal Error

Hallo, ich bin Linux Anfänger und bitte verzweifelt um Hilfe.
Aktuell besteht mein Home Lab aus 2 Raspberry Pis, arm64, auf dem 1 Pi ist noch Bullseye drauf, Docker,Portainer und AdGuardHome, der nicht im Container ist, der Rest sind Containern, siehe Bilder. Und auf dem 2 Bookworm darauf läuft Proxmox, ebenfalls ist auch Docker, Portainer drauf. Der 2 Pi ist meine Lernmaschine derzeit und soll später mal eine Produktivmaschie werden. Der wichtigste Container ist Vaultwarden, den ich auch meiner Familie bereitgestellt habe. Nun zu meinem Problem, es lässt sich kein SSL Zertifikat erstellen, wenn es abläuft, kommen wir nicht mehr an den Vaultwarden rann, da ich nicht weiß wie ich den auch im lokalen Netzwerk bereitstellen kann. Was ich bis jetzt versucht habe, ist AdGuard, Antivirus aus, cach geleert vom Chrome, pi neu gestartet, Ordner rechte angeschaut, 2 Tage google und Bing AI befragt, Fritz!Box resettet, neu eingerichtet. Ich weiß nicht mehr weiter.






linux version






npm rechte

Kommt dein Nginx Proxy Manager ins Internet?
Wenn du auf dem Container des NPM drauf bist, führe einfach mal den Befehl aus:

curl -I https://acme-v02.api.letsencrypt.org/

Daraufhin sollte eine Antwort der Webseite kommen.
image

1 Like

Ja, der kommt raus


ich kann noch https://acme-v02.api.letsencrypt.org/ bei AdGuardHome zur Freigabenliste hinzufügen LE ist schon drin.

Bin ich gerade verwirrt oder warum steht in der NPM GUI als weitergeleiteter Port am Ende mit der 6 und Vaultwarden läuft auf Port-Ende 5 ?

Also im Portainer sieht’s so aus als würde Vaultwarden auf Port 8555 erreichbar sein

In NPM haste aber 8556 eingetragen …

Meines Wissens muss das Ziel erreichbar sein sonst baut NPM kein CERT

Alternativ kannst du auch einmal die Custom Header und ne Custom Location setzen und testen ob es dann klappt.

Habe es gerade mal bei mir im laufenden System getestet.
Es ist egal, ob der Port an der Stelle korrekt ist. Habe im NPM einfach mal einen ungenutzten Port angegeben und er konnte trotzdem ohne Probleme nen Cert erstellen.

Nein, du bist nicht verwirrt, das ist richtig, den auf meinem aktiven pi 1 hat der Valutwarden die IP 192.168.178.28:8555, da ist noch das cert gültig, und da geht es auch nicht. Bei meinem Proxmox pi der zwei IP-Adressen hat, einmal die IP 192.168.178.105 und der LXC wo ich alles frisch eingerichtet habe und da hat der Vaultwarden die IP 192.168.178.109:8556. Ich habe bei dem pi1 die Domäne hinzugefügt wegen der Port Weiterleitung, umgekehrt habe ich es auch schon versucht ohne Erfolg immer der gleiche Fehler.


und der pi 2

ich weiß jetzt nicht, ob im Docker IP V6 stört. Denn ich gebe nur meine IPV4 Adresse weiter bei meinem dündns Anbieter (ddnss.de). Die IPV6 hat mir einer von der Community eingerichtet. Ich weiß auch nicht wie ich dem Docker Netzwerk die IPV6 deaktivieren kann, nicht löschen.

Muss ich bei Edit Proxy bei Custom location bei Define location was ein tragen oder leer lassen?

Ok, damit ist, ausgeschlossen das es am NPM acme certbot liegt, und ja ich habe den NPM auch schon neu ausgerollt es ist komisch den im Portainer kann ich ohne Probleme Images pullen.

Irgendwie habe ich das Gefühl, dass der nicht speichern kann, beim vorherigen Bild konnte ich das nicht löschen und speichern. Es kam wieder internal Error beim erneuten Versuch konnte ich es löschen, der USB-Stick ist neu, der kann ja eigentlich nicht kaputt sein.

Jetzt bin ich auf Version 2.11.0 von NPM



schon mal versucht im npm die subdomain komplett löschen und neu anlegen? manchmal kann auch die config kaputt gehen, hatte ich auch schon mal, einfach löschen und neu anlegen dan ging es plötzlich

Stimmt, es kann passieren, dass die config zum erneuern des Zertifikats kaputt gehen kann. Passiert z.b wenn man den NPM aus nem Backup wiederhergestellt hat. Dann einfach, wie @Andrew_XNET bereits geschrieben hat, einfach das Zertifikat löschen und neu anlegen lassen.

Es geht überhaupt nicht, auf dem pi2 ist alles neu erstellt worden da war noch nie ein cert angelegt worden, bei dem pi1 das mein Hauptsystem ist sind schon certs angelegt und es geht trotzdem nicht, liegt das an meinem Netzwerk oder am Docker Netzwerk. ich kann ja nur eine Domäne anlegen aber kein cert kann erstellt werden.

Kontrolliere mal bitte die Settings in deinem Router bzgl. deines PIs wo NPM drauf läuft, ob Port 80 und 443 nach draußen freigegeben werden.
Und dann prüfe bitte, ob deine Domain, die du im NPM eintragen möchtest, auch auf deinen Router bzw. deine Öffentliche IP zeigt.

Habe es gerade bei mir getestet…wenn die Domain, für die der NPM ein Cert anfragen soll nicht auf deine IP bzw. deinen NPM zeigt, schlägt der Request fehl.

Habe mehr oder weniger die gleich Fehlermeldung:

Wie meist du das mit dem Port? Die sind doch in der Fritzbox freigegeben. Und wie kann ich das bei dem PI einsehen? Ich spiele da nicht herum, wo ich nicht weiß, was ich da tue, Anleitung bitte.

Ich kann empfehlen dir das Video bzw. die Videoreihe von Dennis anzuschauen: (ab min. 13 geht es los mit dem NPM)

Dort erklärt er alles über die Portfreigabe und das die Domain auf deine öffentliche IP zeigen muss.
Ich konnte den Fehler von dir nachstellen und es wird vermutlich an der Domain liegen, die nicht auf deine IP zeigt.

Ich habe es mir angesehen braucht der NPM eine SQL Datenbank? meine yml sieht so aus

version: '3.8'
services:
  app:
    image: 'jc21/nginx-proxy-manager:latest'
    restart: unless-stopped
    ports:
      - '80:80'
      - '81:81'
      - '443:443'
    volumes:
      - /nginxproxymanager/data:/data
      - /nginxproxymanager/letsencrypt:/etc/letsencrypt
    environment:
      PUID: 1000
      PGID: 1000